Jump to content


Important Announcement!

Please read this post

Photo
- - - - -

How view all languages?


  • Please log in to reply
6 replies to this topic

#1 gymka

gymka

    Advanced Member

  • Members
  • 110 posts
  • Gender:Male
  • Location:/dev/sdb1/home


  • Extension Developer: No
  • Translator for Lithuanian (lt)
  • My OS Gnu/Linux
  • Translation Credits to Algimantas Margevičius

Posted 01 December 2011 - 07:31 AM

WTS->All extensions->any extension->if translation for "lt" exists i can't register for it(i can't even see it) i can see only "lt-LT". i understand that which locales to show is set in "profile settings", but there i can't choose "lt" because there is no such option. so if i see "There is no translation available for lt-LT, but for lt " i can't see "lt" translation. as i understand "Show all available localizations" should show all localizations, but that link not works, it loads loads and nothing comes up.(it open locales list 1 time from 10) Same with Firefox and with epiphany.

P.S. why there is a "lt" and "lt-LT"? in Lithuania there is 1 official language and 2 dialects, so if you want to have all possible languages it should be "lt-LT" and "lt-SGS"(Lithuanian-Samogitian)
"Kvailam gimti ne sarmata. Tik mirti kvailam gėda." E. M. Remarkas
"Родиться глупым не стыдно, стыдно только умирать глупцом." Э. М. Ремарк
"To born stupid is not shame, just to die stupid is shameful." E. M. Remarque
"Dumm geboren zu werden ist keine Schande. Nur dumm zu sterben." E. M. Remarque

#2 Goofy

Goofy

    Advanced Member

  • Super Mod
  • 8,435 posts
  • Gender:Male
  • Location:GoofyLand


  • Extension Developer: Yes
  • Extensions: BabelZillaMenu-BabelZilla Glossary-OpenTran...
  • Translator for French (fr)
  • My OS Gnu/Linux
  • Translation Credits to Goofy

Posted 01 December 2011 - 12:57 PM

1/ See this page http://www.babelzill...ype=countrylist spot the "lt" or "lt-LT" line and see "Show Untranslated" link

2/ If you wish to convert semi-manually lt-LT to lt only, just drop a simple request by PM to Fenian so that you have access to the conversion tool which howto is here http://babelwiki.bab...y_language_code


2/ As per "lt" it should be here the only langcode for Lithuanian becaus ewe try to stick to Mozilla official policy in that matter
(http://www.babelzilla.org/index.php?option=com_wts&Itemid=88&type=countrylist) so as long a sthere is no Mozilla app available for lt-XX we don't see the point of having lt-XX extensions
Think Global, Make Locales!


Sometimes I am on irc://moznet/BabelZilla
but you can also drop a word in the shoutbox

#3 Lakrits

Lakrits

    Daredevil Test Pilot

  • Admin
  • 894 posts
  • Gender:Male
  • Location:Uppsala, Sweden
  • Interests:# Science (biology and ecology, mainly botany, mycology, and plant and forest pathology).<br /># Language (words, their use, sounds and flexibility).<br /># Tennis (and almost any other sport, but first and foremost tennis).<br /># Theatrical arts.<br /># … and much more.


  • Extension Developer: No
  • Translator for Swedish (sv-SE)
  • My OS Windows
  • Translation Credits to Mikael Hiort af Ornäs

Posted 01 December 2011 - 04:05 PM

On every extension page, you'll see the green, yellow or red banner that tells you if someone already have registered as translator for the extension.
On the same page, but further down, you'll find two other ways of choosing/examining the translator status:

1. The drop-down (well, most often drop-up) menu "Register me as translator for", and

2. the button "Show all available localizations".



The menu (1) will list all locales that are open, i.e. that have no translators assigned to them. Find your locale in the list and click on "Let's go" to register as translator for that extension.

Clicking on "Show all available localizations" (2) expands a list of all the localisations (or registered translations) for that extension. The list gives you an idea of the translation status for all listed locales, with a link to the translation page (click on the full language name) and a download link for the locale files (click on the language code). On the translation page, you'll be able to see whoever has been translating the extension in the past. Click on his/her nickname to go the user page and send him/her a message to ask if it's alright for you to take over the translation work.


"[…] och han talar med bönder på böndernas sätt
men med lärde män på latin." – Erik Axel Karlfeldt

Lakrits
BabelZilla admin
Moderator for the Swedish BabelZilla forum section

#4 gymka

gymka

    Advanced Member

  • Members
  • 110 posts
  • Gender:Male
  • Location:/dev/sdb1/home


  • Extension Developer: No
  • Translator for Lithuanian (lt)
  • My OS Gnu/Linux
  • Translation Credits to Algimantas Margevičius

Posted 01 December 2011 - 05:05 PM

QUOTE (Lakrits @ Dec 1 2011, 17:05) <{POST_SNAPBACK}>
On every extension page, you'll see the green, yellow or red banner that tells you if someone already have registered as translator for the extension.
On the same page, but further down, you'll find two other ways of choosing/examining the translator status:

1. The drop-down (well, most often drop-up) menu "Register me as translator for", and

2. the button "Show all available localizations".



The menu (1) will list all locales that are open, i.e. that have no translators assigned to them. Find your locale in the list and click on "Let's go" to register as translator for that extension.

Clicking on "Show all available localizations" (2) expands a list of all the localisations (or registered translations) for that extension. The list gives you an idea of the translation status for all listed locales, with a link to the translation page (click on the full language name) and a download link for the locale files (click on the language code). On the translation page, you'll be able to see whoever has been translating the extension in the past. Click on his/her nickname to go the user page and send him/her a message to ask if it's alright for you to take over the translation work.

on time then i posted there was no "lt" entry only "lt-LT"; i saw "show localizations", but as i said it opens menu only 1 of 10 times. as it was said in other topic "it's bugzilla"

"Kvailam gimti ne sarmata. Tik mirti kvailam gėda." E. M. Remarkas
"Родиться глупым не стыдно, стыдно только умирать глупцом." Э. М. Ремарк
"To born stupid is not shame, just to die stupid is shameful." E. M. Remarque
"Dumm geboren zu werden ist keine Schande. Nur dumm zu sterben." E. M. Remarque

#5 Lakrits

Lakrits

    Daredevil Test Pilot

  • Admin
  • 894 posts
  • Gender:Male
  • Location:Uppsala, Sweden
  • Interests:# Science (biology and ecology, mainly botany, mycology, and plant and forest pathology).<br /># Language (words, their use, sounds and flexibility).<br /># Tennis (and almost any other sport, but first and foremost tennis).<br /># Theatrical arts.<br /># … and much more.


  • Extension Developer: No
  • Translator for Swedish (sv-SE)
  • My OS Windows
  • Translation Credits to Mikael Hiort af Ornäs

Posted 01 December 2011 - 06:27 PM

QUOTE (gymka @ Dec 1 2011, 17:05) <{POST_SNAPBACK}>
on time then i posted there was no "lt" entry only "lt-LT"; i saw "show localizations", but as i said it opens menu only 1 of 10 times. as it was said in other topic "it's bugzilla"

I understood that. My post was only to help you find alternative ways to new extensions to translate.

On the page for the Lithuanian (lt) list of untranslated extensions, you find all extension that …

1. … don't have a Lithuanian translation, or
2. … have translations that are abandoned, without a translator or waiting to be reviewed.

Just click an extension in the "untranslated" list to go to its lt locale extension page …



… and then register by clicking the link in the green banner at the top.



But! You have to set lt as your language in your profile settings, otherwise you will be taken to your standard (preset) locale for any extension you go to.

EDIT: Goofy and/or Fenian: For some reason you can't choose lt as your language in the profile settings.
"[…] och han talar med bönder på böndernas sätt
men med lärde män på latin." – Erik Axel Karlfeldt

Lakrits
BabelZilla admin
Moderator for the Swedish BabelZilla forum section

#6 markh

markh

    BZ Jungle Guide

  • Admin
  • 4,051 posts
  • Gender:Male
  • Location:the culinary and touristically unchallenged parts of the Netherlands


  • Extension Developer: No
  • Translator for Dutch (nl)
  • My OS Windows
  • Translation Credits to markh van BabelZilla.org

Posted 01 December 2011 - 08:00 PM

QUOTE (Lakrits @ Dec 1 2011, 18:27) <{POST_SNAPBACK}>
EDIT: Goofy and/or Fenian: For some reason you can't choose lt as your language in the profile settings.

I am neither, but that’s fixed now wink.gif
While the bankers all get their bonuses I’ll just get along with what I’ve got


#7 Lakrits

Lakrits

    Daredevil Test Pilot

  • Admin
  • 894 posts
  • Gender:Male
  • Location:Uppsala, Sweden
  • Interests:# Science (biology and ecology, mainly botany, mycology, and plant and forest pathology).<br /># Language (words, their use, sounds and flexibility).<br /># Tennis (and almost any other sport, but first and foremost tennis).<br /># Theatrical arts.<br /># … and much more.


  • Extension Developer: No
  • Translator for Swedish (sv-SE)
  • My OS Windows
  • Translation Credits to Mikael Hiort af Ornäs

Posted 01 December 2011 - 08:25 PM

QUOTE (markh @ Dec 1 2011, 20:00) <{POST_SNAPBACK}>
I am neither, but that’s fixed now wink.gif

Oh … Sorry wink.gif

Thanks smile.gif

EDIT: Sent a message to gymka letting him know that he now can choose Lithuanian (lt) as default.
"[…] och han talar med bönder på böndernas sätt
men med lärde män på latin." – Erik Axel Karlfeldt

Lakrits
BabelZilla admin
Moderator for the Swedish BabelZilla forum section


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users