Jump to content


Important Announcement!

Please read this post about our new Privacy Policy


Photo

Simple Mail


  • Please log in to reply
140 replies to this topic

#21 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 13 October 2007 - 07:08 PM

Uploaded a new version, it still has a couple of bugs, but should be working.
QUOTE(Almotasim)
Can you add the strings for this alert, please?

Sorry, forgot about this, hope I'll add it in the next version.

Update: Seems that it's too buggy, please wait for the new version.

#22 Fux

Fux

    Rescue & Intervention Super

  • Admin
  • 178 posts
  • Gender:Male
  • Location:Germany


  • Translator for German (de)
  • Extension Developer: No
  • Translation Credits to Fux - BabelZilla.org

Posted 13 October 2007 - 09:04 PM

Hm, en-US is missing (empty strings), so it's not possible to translate it. please.gif
Regards, Fux


Fux is a member of Team erweiterungen.de

Chat: irc://irc.mozilla.org/babelzilla

#23 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 14 October 2007 - 04:15 PM

I've uploaded a new version, which includes localized error messages and addon description

QUOTE(Fux @ Oct 13 2007, 20:04) <{POST_SNAPBACK}>
Hm, en-US is missing (empty strings), so it's not possible to translate it. please.gif

This seems to be a WTS bug: I did "dowload all localed: missing strings blank", and got an archive where all locales are fine, except for en-US, where all strings are blank.


#24 Goofy

Goofy

    Advanced Member

  • Super Mod
  • 8,437 posts
  • Gender:Male
  • Location:GoofyLand


  • Translator for French (fr)
  • Extension Developer: Yes
  • Extensions: BabelZillaMenu-BabelZilla Glossary-OpenTran...
  • Translation Credits to Goofy
  • My OS Gnu/Linux

Posted 14 October 2007 - 05:14 PM

QUOTE
This seems to be a WTS bug: I did "dowload all localed: missing strings blank", and got an archive where all locales are fine, except for en-US, where all strings are blank
.

Ouch, I just gave a test unsure.gif and yes I confirm this is a bug of the new feature recently added.

[edit] I just send a notification to our beloved Tech Admin (but am not sure he has too much time to indulge on that in the moment)
Think Global, Make Locales!


Sometimes I am on irc://moznet/BabelZilla
but you can also drop a word in the shoutbox

#25 Goofy

Goofy

    Advanced Member

  • Super Mod
  • 8,437 posts
  • Gender:Male
  • Location:GoofyLand


  • Translator for French (fr)
  • Extension Developer: Yes
  • Extensions: BabelZillaMenu-BabelZilla Glossary-OpenTran...
  • Translation Credits to Goofy
  • My OS Gnu/Linux

Posted 14 October 2007 - 05:50 PM

QUOTE
I just send a notification to our beloved Tech Admin (but am not sure he has too much time to indulge on that in the moment


closedeyes.gif I was wrong, he fixed it in a giffy! I have tested again, it is running fine now smile.gif
Think Global, Make Locales!


Sometimes I am on irc://moznet/BabelZilla
but you can also drop a word in the shoutbox

#26 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 14 October 2007 - 08:27 PM

Goofy, thanks!

Attention to all translators, please don't translate mail header names in "welcomeMessage" string in simplemail.properties file! The string is:
QUOTE
welcomeMessage= From: Simple Mail <no-reply@localhost>\r\nTo: User <no-reply@localhost>\r\nSubject: Welcome to Simple Mail!\r\n\r\nDear User,\r\n\r\nThank you for trying Simple Mail.\r\n\r\nEnjoy,\r\nSimple Mail

The mail header names are: "From:", "To:" and "Subject:". To verify that welcome letter is sent correctly you can delete (or maybe just temporarily rename, if you want to keep your simple mail accounts/messages) [firefox_profile_folder]/simplemail/ folder and run Firefox. You should see a welcome letter in your inbox.

#27 markh

markh

    BZ Jungle Guide

  • Admin
  • 4,070 posts
  • Gender:Male
  • Location:the culinary and touristically unchallenged parts of the Netherlands


  • Translator for Dutch (nl)
  • Extension Developer: No
  • Translation Credits to markh van BabelZilla.org
  • My OS Windows

Posted 15 October 2007 - 10:26 AM

QUOTE(telega @ Oct 14 2007, 20:27) <{POST_SNAPBACK}>
Attention to all translators, please don't translate mail header names in "welcomeMessage" string in simplemail.properties file! The string is:

The mail header names are: "From:", "To:" and "Subject:". To verify that welcome letter is sent correctly you can delete (or maybe just temporarily rename, if you want to keep your simple mail accounts/messages) [firefox_profile_folder]/simplemail/ folder and run Firefox. You should see a welcome letter in your inbox.

I don't see a welcome message, although it appears in the Attachments folder in my profile. The rest of it works fine, so Dutch locale released cool.gif
While the bankers all get their bonuses I’ll just get along with what I’ve got


#28 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 18 October 2007 - 09:07 AM

Goofy
Hi. Seems that there's another bug in WTS: I did "download all locales (all strings replaced)" and got all locale files correct except for 2 dtd files, where missing strings were blank. My guess is that WTS doesn't replace strings in .dtd files.
BTW, in French translation "helpContents" string is not up to date (english version has changed some time ago).

#29 Almotasim

Almotasim

    Advanced Member

  • Members
  • 130 posts
  • Gender:Male
  • Location:Italy
  • Extension Developer: No

Posted 18 October 2007 - 04:25 PM

Hi telega, would you tell me please the way to show in Firefox these alert strings (of the properties file):

CODE
cantCopyImage=Can't copy image "%S" to images directory
cantRemoveAttachmentsDir=Can't remove attachments directory
cantRemoveImage=Can't remove image: %S
cantRemoveSound=Can't remove sound: %S
messageParseError=Message parse error: %S
noSocksProxySpecified=%S: No SOCKS proxy specified in FF preferences
connectionFailed=%S: Connection failed
invalidResponse=%S: Invalid response: %S
messagesNotFound=%S: Message(s) not found on server
cantPlaySound=Can't play sound: %S
accountNoLongerExist=Account(s) no longer exist
cantCopySound=Can't copy sound "%S" to sounds directory

The it-IT QAgent need to see the related alert windows to correct my localization... smile.gif
Thanks!!

#30 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 18 October 2007 - 07:37 PM

Hi

cantCopyImage=Can't copy image "%S" to images directory
Open Simple Mail Preferences > Address Book, click "Add", then click "Browse", choose image file, click "Open". Chosen file name appears in a text-field. Then open any file manager and rename image file you've chosen. Then go back to the dialog and click OK. An error message should appear in a popup window in the bottom-right screen corner. If you click the link in the message, a console should appear (alternatively open the console from FF "Tools > Error Console" menu"), where you should see the desired error message.

cantRemoveAttachmentsDir=Can't remove attachments directory
Select some message in messages list, right-click, choose "View source" from context menu. In the FF address bar you should see an url: .../some_number_here/message.txt. Then using file manager go to the [firefox_profile]/simplemail/attachments/some_number_here directory and view message.txt file (so that it's in use by file manager and cannot be deleted). Then go back to Simple Mail and delete the original message. An error popup appears, with error message in console.

cantRemoveImage=Can't remove image: %S
Open Simple Mail Preferences > Address Book, click "Add", browse for an image, and click OK. Then in file manager open [firefox_profile]/simplemail/images folder and delete the image you've just assigned. Go back to SM addr. book, click "Edit" the same address, and click "Clear" beside image. An error appears.

cantRemoveSound=Can't remove sound: %S
Open SM Prefs > General, browse for a sound, click OK to close prefs dialog (not sure if this is necessary. Delete sound file in the [firefox_profile]/simplemail/sounds. Open prefs and click "Clear" sound (alternatively you can assign another sound, the old one should be tried to be deleted).

messageParseError=Message parse error: %S
This should happen if a mail message arrives that SM fails to parse, don't know how you can reproduce this.

noSocksProxySpecified=%S: No SOCKS proxy specified in FF preferences
Open FF Preferences > Additional > Network > Settings (not sure what are the exact names, I'm using Russian FF). The dialog should appear for specifying proxy settings. Choose "Manual proxy configuration", but don't fill SOCKS proxy. Then try to "Refresh" mail in SM.

connectionFailed=%S: Connection failed
Specify incorrect server or port in SM POP3 settings and try to "Refresh" mail.

invalidResponse=%S: Invalid response: %S
Specify incorrect login/password in SM POP3 settings (host/port should be correct), and "Refresh" mail.

messagesNotFound=%S: Message(s) not found on server
Delete message(s) on server using your mail server web interface, then choose to delete the message(s) in SM and specify "Delete from server" checkbox. An error should appear.

cantPlaySound=Can't play sound: %S
Assign a sound in SM Prefs > General, delete the sound file using file manager in [ff_profile]/simplemail/sounds folder and try to "Refresh" mail. If there're new messages, SM will try to play sound, and the error occurs.

accountNoLongerExist=Account(s) no longer exist
Click to create "New" message, choose "From" field. Then open SM preferences and delete the account related to the selected email. Then click "Send".

cantCopySound=Can't copy sound "%S" to sounds directory
This shouldn't generally happen, this happens if SM can't copy sound you select in SM Prefs > General after you click "Open" after browsing for a file.

Uff...seems that's all

#31 Almotasim

Almotasim

    Advanced Member

  • Members
  • 130 posts
  • Gender:Male
  • Location:Italy
  • Extension Developer: No

Posted 19 October 2007 - 11:09 AM

Thank you very much telega, and sorry for this effort, it's been very apreciated!! smile.gif

#32 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 19 October 2007 - 12:04 PM

No problem smile.gif


#33 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 19 October 2007 - 06:07 PM

BTW, just uploaded a new version to WTS. Before uploading I did "download all locales(all strings blank)", and after the upload I see that WTS counts empty strings as translated when displaying translation percentage. sad.gif

#34 Goofy

Goofy

    Advanced Member

  • Super Mod
  • 8,437 posts
  • Gender:Male
  • Location:GoofyLand


  • Translator for French (fr)
  • Extension Developer: Yes
  • Extensions: BabelZillaMenu-BabelZilla Glossary-OpenTran...
  • Translation Credits to Goofy
  • My OS Gnu/Linux

Posted 19 October 2007 - 06:12 PM

QUOTE(telega @ Oct 19 2007, 19:07) <{POST_SNAPBACK}>
BTW, just uploaded a new version to WTS. Before uploading I did "download all locales(all strings blank)", and after the upload I see that WTS counts empty strings as translated when displaying translation percentage. sad.gif


Notoriously our progressmeter is NOT to be trusted, please ignore it.
Think Global, Make Locales!


Sometimes I am on irc://moznet/BabelZilla
but you can also drop a word in the shoutbox

#35 Fux

Fux

    Rescue & Intervention Super

  • Admin
  • 178 posts
  • Gender:Male
  • Location:Germany


  • Translator for German (de)
  • Extension Developer: No
  • Translation Credits to Fux - BabelZilla.org

Posted 21 October 2007 - 01:09 PM

de-DE released.
Bug in version 2.02 : Adding images is not possible, getting error in console:
CODE
Fehler: uncaught exception: [Exception... "'[JavaScript Error: "toJavaScriptConsole is not defined" {file: "chrome://simplemail/content/utils.js" line: 70}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/alerts/alert.js :: onAlertClick :: line 222"  data: yes]

Regards, Fux


Fux is a member of Team erweiterungen.de

Chat: irc://irc.mozilla.org/babelzilla

#36 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 21 October 2007 - 01:43 PM

QUOTE(Fux @ Oct 21 2007, 12:09) <{POST_SNAPBACK}>
de-DE released.
Bug in version 2.02 : Adding images is not possible, getting error in console:
CODE
Fehler: uncaught exception: [Exception... "'[JavaScript Error: "toJavaScriptConsole is not defined" {file: "chrome://simplemail/content/utils.js" line: 70}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/alerts/alert.js :: onAlertClick :: line 222"  data: yes]

Thanks for the catch! Will be fixed in a new version.
BTW, do you really use this function (assigning an image to a contact) or you were just testing it? I'm asking because I'm considering removal of this function, as I don't use it myself and have no information if anyone uses it.

#37 Fux

Fux

    Rescue & Intervention Super

  • Admin
  • 178 posts
  • Gender:Male
  • Location:Germany


  • Translator for German (de)
  • Extension Developer: No
  • Translation Credits to Fux - BabelZilla.org

Posted 21 October 2007 - 02:26 PM

QUOTE(telega @ Oct 21 2007, 14:43) <{POST_SNAPBACK}>
BTW, do you really use this function (assigning an image to a contact) or you were just testing it? I'm asking because I'm considering removal of this function, as I don't use it myself and have no information if anyone uses it.


I was just testing it.

Regards, Fux


Fux is a member of Team erweiterungen.de

Chat: irc://irc.mozilla.org/babelzilla

#38 markh

markh

    BZ Jungle Guide

  • Admin
  • 4,070 posts
  • Gender:Male
  • Location:the culinary and touristically unchallenged parts of the Netherlands


  • Translator for Dutch (nl)
  • Extension Developer: No
  • Translation Credits to markh van BabelZilla.org
  • My OS Windows

Posted 22 October 2007 - 01:59 PM

Dutch locale updated, tested and released cool.gif

The image adding doesn't work for me anymore either, nor does changing the image (but I guess that's the same piece of code) ohmy.gif
While the bankers all get their bonuses I’ll just get along with what I’ve got


#39 Almotasim

Almotasim

    Advanced Member

  • Members
  • 130 posts
  • Gender:Male
  • Location:Italy
  • Extension Developer: No

Posted 23 October 2007 - 03:21 PM

QUOTE(Almotasim @ Oct 18 2007, 15:25) <{POST_SNAPBACK}>
Hi telega, would you tell me please the way to show in Firefox these alert strings (of the properties file):

CODE
cantCopyImage=Can't copy image "%S" to images directory
cantRemoveAttachmentsDir=Can't remove attachments directory
cantRemoveImage=Can't remove image: %S
cantRemoveSound=Can't remove sound: %S
...

The it-IT QAgent need to see the related alert windows to correct my localization... smile.gif
Thanks!!


QUOTE(telega @ Oct 18 2007, 18:37) <{POST_SNAPBACK}>
Hi

cantCopyImage=Can't copy image "%S" to images directory
Open Simple Mail Preferences > Address Book, click "Add", then click "Browse"...


Hi telega, I'm back to stress you again... rolleyes.gif
I'm sorry, but the QCAgents can't see the alert windows, here is an example:
http://www.box.net/shared/negrsz2eer
They followed your explanations on a new Firefox profile but the extension didn't work correctly, so they couldn't test the strings I posted before.
Do you think that the extension could have some bugs?

Thanks,
A.

#40 telega

telega

    Advanced Member

  • Members
  • 92 posts
  • Location:Belarus
  • Translator for [No translator]
  • Extension Developer: Yes
  • Extensions: Simple Mail
    Fast Dial
    Fire Analytics

Posted 25 October 2007 - 06:35 AM

QUOTE(Almotasim @ Oct 23 2007, 14:21) <{POST_SNAPBACK}>
Do you think that the extension could have some bugs?

Yes, I confirm there was a bug, the console didn't open when clicking on "See console" link. This should be fixed in the new version 2.03 I uploaded. BTW there isn't "Can't copy image to images directory" message string anymore, because I removed possibility to assign an image to a contact. Instead there's a new feature - assign different colors to accounts, so that messages belonging to different accounts are shown in different colors. (BTW, do these icons look OK? Or they are hard to distinguish? Maybe make the icons filled with a selected color?)
Also error messages now are shown in message box by default. To make errors shown in a popup, set "extensions.simplemail.errorMessageBox" preference to "0".


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users