Jump to content


Important Announcement!

Please read this post about our new Privacy Policy


Photo

Forward - Ver. 0.19


  • Please log in to reply
38 replies to this topic

#21 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 15 December 2011 - 08:12 PM

QUOTE (ibraheem_alex @ Dec 13 2011, 23:24) <{POST_SNAPBACK}>
Arabic local (ar) released.


Thanks again! I'll release this version in the beginning of 2012...
I give my other translators some more time to update their locales

#22 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 27 January 2012 - 02:13 PM

QUOTE (oeekker @ Dec 6 2011, 09:50) <{POST_SNAPBACK}>
Hi alfapegasi,
Thank you for the offer. I only sent out an update request last week, so I'd like to give my current translators a little more time to react. If I don't get a reply from DepressiveGuN soon, I'll open up the Turkish translation for you...
Onno


Hi again alfapegasi,
I've opened up the Turkish localization for other members, so you can join the team of you're still interested.
Onno

#23 alfapegasi

alfapegasi

    Advanced Member

  • Members
  • 112 posts

Posted 01 February 2012 - 01:18 PM

Thanks... tr is released

QUOTE (oeekker @ Jan 27 2012, 15:13) <{POST_SNAPBACK}>
Hi again alfapegasi,
I've opened up the Turkish localization for other members, so you can join the team of you're still interested.
Onno

cheers,

Sinan.


#24 erglo

erglo

    Advanced Member

  • Members
  • 252 posts

Posted 30 June 2012 - 04:59 PM

German de-locale updated and released.

#25 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 30 June 2012 - 08:31 PM

QUOTE (erglo @ Jun 30 2012, 17:59) <{POST_SNAPBACK}>
German de-locale updated and released.


Hi Erwin,
I think something went wrong with babelzilla, because I see 0 translated strings in filter.properties. Can you please check the file again?
Onno

#26 erglo

erglo

    Advanced Member

  • Members
  • 252 posts

Posted 01 July 2012 - 10:36 AM

Ups, sorry!
It wasn't BabelZilla, I mixed something up after testing the add-on. wacko.gif
Should be ok now.

QUOTE (oeekker @ Jun 30 2012, 21:31) <{POST_SNAPBACK}>
Hi Erwin,
I think something went wrong with babelzilla, because I see 0 translated strings in filter.properties. Can you please check the file again?
Onno


#27 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 01 July 2012 - 08:39 PM

Starting from Forward version 0.15 I've changed the packaging for Forward on babelzilla. Instead of packaging the chrome files in a jar, I now upload them unzipped. I think this was recommended since Thunderbird version 6.0, so it was about time I followed suit. Hopefully this will make it easier for translators to test their translations. I'll see if I can add the em:unpack tag to install.rdf next time I upload the extension, which will make it even more easier for you to add or update a locale...

#28 Joergen

Joergen

    Advanced Member

  • Members
  • 406 posts

Posted 22 November 2012 - 04:33 PM

Hi oeekker

Are you sure the add-on are displaying the strings header.inline.label and header.asAttachment.label?
The texts in the drop down button on the header is different form the ones in the drop down button on the toolbar.
It looks like the texts in the header button are the same as those in the context menu.

Joergen


#29 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 23 November 2012 - 03:31 PM

QUOTE (Joergen @ Nov 22 2012, 17:33) <{POST_SNAPBACK}>
Hi oeekker

Are you sure the add-on are displaying the strings header.inline.label and header.asAttachment.label?
The texts in the drop down button on the header is different form the ones in the drop down button on the toolbar.
It looks like the texts in the header button are the same as those in the context menu.

Joergen


Hi Jørgen,

I did change the code to only initialize the optional strings once. After your post I rechecked my code, but I couldn't find anything wrong with it... The header.inline.label and header.asAttachment.label are always shown on the Header Forward button menu list. See also the following image:


The texts in the Mail toolbar header button are first copied from the strings from Tools | Options | Composition | General | Forward messages, but are overruled with the translated strings in your localized forward.properties.

The texts in the message (right-click) context menu are first copied from the strings from Message | Forward As | Inline / As Attachment, but are also overruled with the translated string in your localized forward.properties.

With which version of Thunderbird did you test? And on what OS?

Onno

#30 Joergen

Joergen

    Advanced Member

  • Members
  • 406 posts

Posted 23 November 2012 - 05:28 PM

Hi Onno

I tested my localization with the latest version from BabelZilla (0.16).
What puzzled me was the difference between the two buttons.
I would expect the two buttons to contain the same strings.

The first image is from the header. The second image is from the toolbar (that is ok).
Joergen

Attached Files



#31 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 23 November 2012 - 09:25 PM

QUOTE (Joergen @ Nov 23 2012, 18:28) <{POST_SNAPBACK}>
Hi Onno

I tested my localization with the latest version from BabelZilla (0.16).
What puzzled me was the difference between the two buttons.
I would expect the two buttons to contain the same strings.

The first image is from the header. The second image is from the toolbar (that is ok).
Joergen


Originally the Mail toolbar button and the message header button were different, because the message header had lower case characters (at least in English locale). Apparently this changed in Thunderbird 9.0 with bug 478468 (lowercase interface elements in message window header bar are inconsistent UI (mail header labels and button labels should be capitalized)). Thanks to your message I just now notice this...

This means I have to change the English strings for the header forward button to be capitalized too and I also need to change the instructions. I'm not sure yet on how to change this. I could add new renamed strings and drop the original strings to make sure all locales get updated the right way, or I could just leave the strings the way they are and send a notice to all localizers...

Hmm, tough decision. I'll think about it a bit longer and will upload am updated v0.16 next week.

#32 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 23 November 2012 - 09:34 PM

QUOTE (Joergen @ Nov 23 2012, 18:28) <{POST_SNAPBACK}>
Hi Onno

I tested my localization with the latest version from BabelZilla (0.16).
What puzzled me was the difference between the two buttons.
I would expect the two buttons to contain the same strings.

The first image is from the header. The second image is from the toolbar (that is ok).
Joergen


Hmm... Seeing that you translated toolbar.inline.* the same as header.inline.* I indeed don't understand how your header button can come up with different strings. I'm puzzled here as well unsure.gif

#33 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 27 November 2012 - 01:16 PM

Thanks to Jørgen I noticed an error in my extension. With Thunderbird 9.0 the strings in the header Forward button changed from lower case to being capitalized. Because my extension is backwards compatible with Thunderbird to version 1.5 I need both lower case and capitalized strings. Therefore I have added three new strings: header.inline.label1, header.asAttachment.label1 and hdrForwardButton.tooltip1 that are used in Thunderbird 9.0 and up. The original strings are used in Thunderbird 1.5 .. 8.*

Please check your translation and see if you have the strings in lower case or capitalized and add the strings for the older or newer version...

#34 Joergen

Joergen

    Advanced Member

  • Members
  • 406 posts

Posted 27 November 2012 - 03:42 PM

Hi Onno

I was still having this problem with version 0.16-1. Then I disabled the add-on CompactHeader 2.0.6, and the problem was gone!


Joergen

#35 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 28 November 2012 - 08:52 AM

QUOTE (Joergen @ Nov 27 2012, 16:42) <{POST_SNAPBACK}>
Hi Onno

I was still having this problem with version 0.16-1. Then I disabled the add-on CompactHeader 2.0.6, and the problem was gone!


Joergen


Hmz, that's a featured extension with 263,978 users...
I suppose I need to make Forward compatible with that extension too sad.gif

#36 oeekker

oeekker

    Advanced Member

  • Members
  • 94 posts

Posted 28 November 2012 - 01:21 PM

QUOTE (oeekker @ Nov 28 2012, 09:52) <{POST_SNAPBACK}>
Hmz, that's a featured extension with 263,978 users...
I suppose I need to make Forward compatible with that extension too sad.gif


Hi Jørgen,
I added some code to also use my header button menuitems with the Compact Header extension installed.
The CompactHeader extension hides/collapses the original header (Reply and) Forward button and copies them from the toolbar.
Version 0.16-2 should fix this and use my strings again.
Of course it's up to you to make the strings header.inline.label1 and header.asAttachment.label1 the same as toolbar.inline.label and toolbar.asAttachment.label...
Onno

#37 Joergen

Joergen

    Advanced Member

  • Members
  • 406 posts

Posted 07 December 2012 - 08:49 PM

QUOTE (oeekker @ Nov 28 2012, 13:21) <{POST_SNAPBACK}>
Hi Jørgen,
I added some code to also use my header button menuitems with the Compact Header extension installed.
The CompactHeader extension hides/collapses the original header (Reply and) Forward button and copies them from the toolbar.
Version 0.16-2 should fix this and use my strings again.
Of course it's up to you to make the strings header.inline.label1 and header.asAttachment.label1 the same as toolbar.inline.label and toolbar.asAttachment.label...
Onno


Hi Onno

Version 0.16-2 works fine.

Joergen

#38 erglo

erglo

    Advanced Member

  • Members
  • 252 posts

Posted 13 January 2013 - 12:50 PM

German locale updated, tested and released.

(Sorry for the delay.) sad.gif

#39 erglo

erglo

    Advanced Member

  • Members
  • 252 posts

Posted 28 April 2014 - 07:34 PM

German locale (de) updated, tested and released.


2 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    CCBot (2)