Jump to content


Important Announcement!

Please read this post about our new Privacy Policy


Photo

AutoCopy 2 - Ver. 1.2.7.1


  • Please log in to reply
39 replies to this topic

#21 Sonickydon

Sonickydon

    [el-GR] Coordinator

  • BabelZillian Mods
  • 768 posts

Posted 06 July 2012 - 04:12 PM

One last comment (which I forgot earlier):

Keep in mind that some locales do not use the latin alphabet or keyboard. The shortcut key combinations you provide in the preferences menu are all based on it.
That's a minor issue and most likely nobody will have a problem with it (90% of the users who care to use and -most importantly- set shortcuts, are advanced users/programmers and therefor used to the latin keyboard anyway.)

Thanks for the quick fix on the quotation marks smile.gif
(Just for your information: It's nice that you provide an option to localize the extension's name, but since our team is too small to provide support for extensions, we avoid to localize extension names so that the users will be able to find support on the web in case they need it. Thus the string will remain in english).
Graecum est, non legitur

#22 ZuGro

ZuGro

    Advanced Member

  • Members
  • 311 posts

Posted 07 July 2012 - 05:24 AM

Hi

Some remarks about the new customizable quotation marks:

1.
In locales where the double quotes (") are used (even in the en-US locale), we need to escape them with a backslash (\), because that character is a reserved one from that language.

Using simple (") as they was uploaded to WTS, causes a error in the code of options.xul and options.js files (displayed in error console), escaping the values of both new keys in autocopy.properties file (both with the double quotes), the error is gone...

2.
For the key "autocopy-context-menu-quot1", we need also insert a blank space before the quotation mark (even before his escaping character backslash), in order to get this: Search for: "Selected text to search for" instead of: Search for:"Selected text to search for", but WTS deletes the (starting) blank space from the value of this key. Then we need to add a blank space at the en of "autocopy-context-menu-searchfor" key value to workaround the issue (must be "Search for: " instead of "Search for:"), same applies to Spanish locale as well.

Testing Spanish [es-MX] now...

Best regards.

EDIT:

About the #2 remark, does not work any of my 2 suggestions (blank space at the beginning of "autocopy-context-menu-quot1" key value and/or blank space at end of "autocopy-context-menu-searchfor" key value), that's because in the properties files the spaces at beginning or end of key's values are skipped (ignored, omitted)...

Why not simply change "autocopy-context-menu-searchfor" string to include the first quotation mark?, like this: Search for: \"
If this is implemented, only a single new key will be needed (for the second quotation mark only), so you can delete the "autocopy-context-menu-quot1" because is obsolete but keep "autocopy-context-menu-quot2" as well.

Best regards.

EDIT (last edit I hope):

It's working, solved leaving "autocopy-context-menu-quot1" key value empty and using (Search for: \") in "autocopy-context-menu-searchfor" key value.

Best regards again...

PS: how hardy is write in English to me, sorry my misspellings please!

#23 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 09 July 2012 - 01:05 AM

QUOTE (ZuGro @ Jul 7 2012, 05:24) <{POST_SNAPBACK}>
Some remarks about the new customizable quotation marks:
1.
In locales where the double quotes (") are used (even in the en-US locale), we need to escape them with a backslash (\), because that character is a reserved one from that language.

Thanks for your catch. In the final release I corrected this issue manually. In the next versions will be special note for translators.

QUOTE (ZuGro @ Jul 7 2012, 05:24) <{POST_SNAPBACK}>
2.
For the key "autocopy-context-menu-quot1", we need also insert a blank space before the quotation mark (even before his escaping character backslash), in order to get this: Search for: "Selected text to search for" instead of: Search for:"Selected text to search for", but WTS deletes the (starting) blank space from the value of this key. Then we need to add a blank space at the en of "autocopy-context-menu-searchfor" key value to workaround the issue (must be "Search for: " instead of "Search for:"), same applies to Spanish locale as well.

In the final release this space was added in the code, so any translation corrections are redundant.
Teo

#24 Sonickydon

Sonickydon

    [el-GR] Coordinator

  • BabelZillian Mods
  • 768 posts

Posted 12 August 2012 - 09:00 PM

QUOTE
If you enjoy this add-on, please consider help support continued development by making a small contribution.


I think this sentence doesn't make much sense in english.
Suggestion:
QUOTE
If you enjoy this add-on, please consider supporting it's development by making a small contribution/donation.

Graecum est, non legitur

#25 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 13 August 2012 - 12:38 AM

QUOTE (Sonickydon @ Aug 12 2012, 21:00) <{POST_SNAPBACK}>
I think this sentence doesn't make much sense in english.
Suggestion:

Thank you for your suggestion. This sentence include part of sentence from AMO, but your suggestion is OK, so finally I'll change to your suggestion.
Teo

#26 DakSrbija

DakSrbija

    Advanced Member

  • BabelZillian Mods
  • 422 posts

Posted 18 August 2012 - 10:02 PM

Serbian (sr) localization has been released.

#27 ZuGro

ZuGro

    Advanced Member

  • Members
  • 311 posts

Posted 20 August 2012 - 10:32 AM

Hi

Spanish [es-MX] updated...

@teo:
I have another video showing a little issue when copying some text with bullets (like the list of the Auto Copy 2 on AMO, "About this add-on" section) - (the text is not copied), do you want to see it?

Also, please change the target address of the "Contribute" button (in the new installed add-on page), delete the "/pl/" part, because that gives the user to the Polish page of Auto Copy 2 on AMO (best without any language reference, so the page will be redirected automatically to the right language for each user)
Maybe must be:
CODE
https://addons.mozilla.org/firefox/addon/autocopy-2/?src=ss


Best regards.

#28 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 20 August 2012 - 12:05 PM

QUOTE (ZuGro @ Aug 20 2012, 10:32) <{POST_SNAPBACK}>
@teo:
I have another video showing a little issue when copying some text with bullets (like the list of the Auto Copy 2 on AMO, "About this add-on" section) - (the text is not copied), do you want to see it?

I can't reproduce this issue. I'm using AutoCopy all the time and text in bullets is copied. Yes, of course. I always like watch your cool videos.

QUOTE (ZuGro @ Aug 20 2012, 10:32) <{POST_SNAPBACK}>
Also, please change the target address of the "Contribute" button (in the new installed add-on page), delete the "/pl/" part, because that gives the user to the Polish page of Auto Copy 2 on AMO (best without any language reference, so the page will be redirected automatically to the right language for each user)
Maybe must be:
CODE
https://addons.mozilla.org/firefox/addon/autocopy-2/?src=ss

Thanks for your catch. This link was corrected.

Regards
Teo
Teo

#29 Joergen

Joergen

    Advanced Member

  • Members
  • 406 posts

Posted 05 October 2012 - 01:23 PM

Hi teo

Did you just change the string
"Copy Plain Text 2 extension have to be installed and enable for this feature to work." in the file autocopy.properties to:
"Copy Plain Text 2 extension have to be installed for this feature to work.\n\nCopy Plain Text 2 isn't installed. Do you want to install it now?"?
It looks like a regression.
When will a user see the new string "Incorrect URL form"?

Joergen

#30 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 06 October 2012 - 01:32 AM

QUOTE (Joergen @ Oct 5 2012, 13:23) <{POST_SNAPBACK}>
Did you just change the string
"Copy Plain Text 2 extension have to be installed and enable for this feature to work." in the file autocopy.properties to:
"Copy Plain Text 2 extension have to be installed for this feature to work.\n\nCopy Plain Text 2 isn't installed. Do you want to install it now?"?
It looks like a regression.

It was a momentary lapse. Should be "Copy Plain Text 2 extension have to be installed and enable for this feature to work."

QUOTE (Joergen @ Oct 5 2012, 13:23) <{POST_SNAPBACK}>
When will a user see the new string "Incorrect URL form"

This info is displayed when you copy e.g. text and using "Open in new tab" option from context menu . This feature working only if copied string is URI address beginning with https://, http://, ftp://, file://, and www. When copied string not start with these prefixes, is displayed alert "Incorrect URL form". When I was uploaded add-on to BabelZilla, this functionality was under development, so can not working properly. Now all is OK, and I'm waiting for translations.
Teo

#31 Joergen

Joergen

    Advanced Member

  • Members
  • 406 posts

Posted 23 January 2013 - 01:16 PM

Hi Teo

The Danish locale has been updated.
There is a problem with autocopy.dtd <!ENTITY pref.autocopyBlacklistGroupPlaceholder "&lt;insert domain name&gt;">. I think BabelZilla is converting it to "<insert domain name>".
You might have to fix this manually before you release the next version.

Joergen

#32 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 23 January 2013 - 03:09 PM

QUOTE (Joergen @ Jan 23 2013, 13:16) <{POST_SNAPBACK}>
Hi Teo

The Danish locale has been updated.
There is a problem with autocopy.dtd <!ENTITY pref.autocopyBlacklistGroupPlaceholder "&lt;insert domain name&gt;">. I think BabelZilla is converting it to "<insert domain name>".
You might have to fix this manually before you release the next version.

Joergen


Thanks for your quickly translation and catch. I know about this WTS issue and manually changed to proper signs before release.
Teo

#33 k2jp

k2jp

    Newbie

  • Members
  • 5 posts

Posted 27 January 2013 - 01:34 AM

QUOTE (teo @ May 27 2011, 19:56) <{POST_SNAPBACK}>
Included locales: cs da de el en-US es es-AR es-MX fr hu it ja ko pl pt-BR pt-PT ru sk sk-SK sr sv-SE tr zh-CN zh-TW

View on WTS


ja locale is missing, ONLY on WTS.
But downloaded locale archive still has ja locale.

What's happening? wacko.gif

#34 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 27 January 2013 - 02:10 AM

QUOTE (k2jp @ Jan 27 2013, 01:34) <{POST_SNAPBACK}>
ja locale is missing, ONLY on WTS.
But downloaded locale archive still has ja locale.

What's happening? wacko.gif

Thanks for your catch. I informed admins about this problem.
Teo

#35 Haebaru

Haebaru

    Advanced Member

  • Members
  • 45 posts

Posted 30 January 2013 - 01:28 PM

Hi,

AutoCopy 2 options are not displayed.
xml burst error message appears.

I don't know what it's happening. please.gif


#36 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 30 January 2013 - 01:56 PM

QUOTE (Haebaru @ Jan 30 2013, 13:28) <{POST_SNAPBACK}>
Hi,

AutoCopy 2 options are not displayed.
xml burst error message appears.

I don't know what it's happening. please.gif


Hi,
In the file autocopy.dtd change line 28
CODE
<!ENTITY pref.autocopyBlacklistGroupPlaceholder "<ドメイン名の入力>">

to

CODE
<!ENTITY pref.autocopyBlacklistGroupPlaceholder "&lt;ドメイン名の入力&gt;">

Teo

#37 Haebaru

Haebaru

    Advanced Member

  • Members
  • 45 posts

Posted 02 February 2013 - 04:47 AM

ja locale updated.

teo,Thanks! laugh.gif

#38 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 02 February 2013 - 02:12 PM

QUOTE (Haebaru @ Feb 2 2013, 04:47) <{POST_SNAPBACK}>
ja locale updated.

teo,Thanks! laugh.gif

With pleasure. smile.gif
Teo

#39 ZuGro

ZuGro

    Advanced Member

  • Members
  • 311 posts

Posted 14 April 2013 - 07:06 AM

Hi

Spanish (es-MX) locale updated & released...

PS: please, don't forget to change the "<" & ">" characters to &lt; and &gt; respectively, because I can't (WTS changes &gt; to ">" and &lt; to "<" on every attempt to save the changes)
(It was necessary to change that characters manually in the downloaded files, in order to test the extension/translation)

Best regards.

#40 teo

teo

    XUL Warrior & Layout Fakir

  • BabelZillian Mods
  • 1437 posts

Posted 14 April 2013 - 10:55 AM

QUOTE (ZuGro @ Apr 14 2013, 07:06) <{POST_SNAPBACK}>
Hi

Spanish (es-MX) locale updated & released...

PS: please, don't forget to change the "<" & ">" characters to &lt; and &gt; respectively, because I can't (WTS changes &gt; to ">" and &lt; to "<" on every attempt to save the changes)
(It was necessary to change that characters manually in the downloaded files, in order to test the extension/translation)

Best regards.

Thanks for your catch, but I'm testing all locales before release.
Teo


1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    CCBot (1)