Jump to content


Important Announcement!

Please read this post about our new Privacy Policy


Photo
- - - - -

End-of-line (\u000D\u000A) not encoded in downloaded .properties files


  • Please log in to reply
2 replies to this topic

#1 P.A.

P.A.

    Advanced Member

  • Members
  • 60 posts
  • Extension Developer: Yes
  • Extensions: Mozilla Archive Format

Posted 07 December 2008 - 05:42 PM

Hello,

in the Mozilla Archive Format extension, loaded in the WTS at:
http://www.babelzilla.org/index.php?option=com_wts&Itemid=51&extension=4500&type=lang

I have a properties file named:
locale/en-US/preferences/prefsDialog.properties

and the original English file contains the line:
associate.failed.msg=Unable to create the file association: %S.\u000D\u000A\u000D\u000AMake sure you have administrator privileges on the system.

When I download the file from the WTS, the result is like this:
associate.failed.msg=Unable to create the file association: %S.

Make sure you have administrator privileges on the system.


This obviously would break the ".properties" file in Firefox.

Is there a way to tell the WTS to encode all the Unicode characters in the donloaded files?

Does the new WTC exhibit this behavior too?

Thanks,
Paolo Amadini

#2 PiVV

PiVV

    Advanced Member

  • Members
  • 273 posts
  • Gender:Male
  • Location:xUSSR, Ukraine, Odessa


  • Translator for Russian
  • Extension Developer: No
  • Translation Credits to Пирятинский Виталий

Posted 07 December 2008 - 06:30 PM

Try to use instead the following code: \n
I thank the alphabet for kindly given letters.

#3 P.A.

P.A.

    Advanced Member

  • Members
  • 60 posts
  • Extension Developer: Yes
  • Extensions: Mozilla Archive Format

Posted 07 December 2008 - 08:25 PM

QUOTE (PiVV @ Dec 7 2008, 18:30) <{POST_SNAPBACK}>
Try to use instead the following code: \n


It worked. Thanks! smile.gif


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users